GeekPolice Tech TutorialsLog in

 


Windows 10 Won’t Use Full Memory (RAM)

Share

20190505
Windows 10 Won’t Use Full Memory (RAM)

Windows 10 Won’t Use Full Memory (RAM)

Windows 10 users reported that they noticed that only a part of the total amount of RAM is currently usable by Windows. In some cases, they would see an unusual large amount of RAM been “Hardware Reserved” by the Windows in the Task manager.

There are some configurations in Windows 10 and your motherboard’s BIOS that can reserve some amount of RAM making them unusable. They can be easily changed and are listed in the solutions below.

    Note
If you have a 32 bit version of Windows 10 operating system installed, you can only use 3.5GB RAM. You will need to install a 64 bit Windows 10 operating system to use more than 3.5GB RAM.



Modify RAM used on Boot

This alternative in Windows is utilized to reserve RAM that is utilized during the bot procedure when your system is turning on. By default, it may permanently and unnecessarily reserve a significantly large amount of RAM for it.

To set that right, press Windows + R keys to open Run dialog box.  Type msconfig in the Run dialog box and Press Enter key.

Windows 10 Won’t Use Full Memory (RAM) UMWGbXh

System Configuration window will open. Go to the Boot tab in it.

Select your Operating system from the list below if you have more than one. Now click on Advanced Options button.

On the upper right corner, Clear the checkbox next to Maximum memory. Click Ok.

Windows 10 Won’t Use Full Memory (RAM) WHffEke

Now restart your computer. Check of the issue resolved. If not, move on to the next solution.



Modify BIOS Settings

If you have a separate dedicated video card installed, then you have to make sure the internal graphic processing unit (iGPU) is off which is is used in case you don’t have any external one. If it is On, Windows can be reserving the memory for it.

In the BIOS setup, search for iGPU, Internal Graphics or Onboard Graphics. The name and location of this setting can once again vary according to your system’s manufacturer so you will have to search it. Once you find it, make sure it is Disabled or turned Off.

Also in BIOS , there is a Memory Map Feature that can give Windows full access to the RAM installed. Search for it and make sure it is Enabled or turned On.

Comments

No Comment.
Permissions in this forum:
You cannot reply to topics in this forum